Uploaded image for project: 'OpenSAML - C++'
  1. OpenSAML - C++
  2. CPPOST-26

RequireValidUntilMetadataFilter reports wrong type

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Trivial
    • Resolution: Fixed
    • Affects Version/s: 2.1
    • Fix Version/s: 2.2
    • Component/s: Metadata
    • Labels:
      None
    • Operating System:
      Multiple
    • CPU Type:
      Multiple
    • C/C++ Compiler:
      Multiple

      Description

      When loading a MetadataFilter of type RequireValidUntil
      <MetadataFilter type="RequireValidUntil" maxValidityInterval="604800"/>
      shibd.log reports:
      INFO OpenSAML.Metadata [4637]: applying metadata filter (Blacklist)
      The log message should report "applying metadata filter (RequireValidUntil)" instead. The MetadataFilter's id is not correctly defined.

      Attached: proposed patch to cpp-opensaml2/branches/REL_2/saml/saml2/metadata/impl/RequireValidUntilMetadataFilter.cpp.

        Attachments

          Activity

            People

            Assignee:
            cantor.2@osu.edu Scott Cantor
            Reporter:
            edysli Etienne Dysli
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: