Uploaded image for project: 'Identity Provider'
  1. Identity Provider
  2. IDP-590

Activation surpressed Attribute resolver still issues a warning

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 3.0.0
    • Fix Version/s: 3.1.0
    • Component/s: Attribute Resolver
    • Labels:
      None

      Description

      As noted in the Shibboleth users list:

      > If I use activationCondition in a attribute definition
      > (attribute-resolver.xml), if the activationCondition doesn't match, I
      > read a log line like:
      >
      > 015-02-05 13:49:50,185 - WARN
      > [net.shibboleth.idp.attribute.resolver.impl.AttributeResolverImpl:270] -
      > Attribute Resolver 'ShibbolethAttributeResolver': Attribute definition
      > 'federa_cognome' produced no attribute

        Attachments

          Activity

            People

            Assignee:
            rdw@iay.org.uk Rod Widdowson
            Reporter:
            rdw@shibboleth.net Rod Widdowson
            Watchers:
            4 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Time Tracking

                Estimated:
                Original Estimate - Not Specified
                Not Specified
                Remaining:
                Remaining Estimate - 0 minutes
                0m
                Logged:
                Time Spent - 1 hour, 40 minutes
                1h 40m