Uploaded image for project: 'Identity Provider'
  1. Identity Provider
  2. IDP-723

ACS not visible in RelyingPartyUIContext

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Invalid
    • Affects Version/s: 3.1.1
    • Fix Version/s: None
    • Component/s: Logout, User Interface
    • Labels:
      None
    • Environment:

      IdP 3.1.1 on CentOS 6 with Tomcat7

      Description

      Hi,

      I'm customizing the Logout page (logout.vm) and I'm not getting the ServiceName displayed.

      On the logout page, I see $rpUIContext.getServiceName() returning just the name derived from the entityId.

      Looking into net.shibboleth.idp.ui.context.RelyingPartyUIContext, and considerig the logout message seen ("No name in UIINFO for 'en') and not seen (no output from getNameFromAttributeConsumingService), it appears as if getRPAttributeConsumingService was returning null / rpAttributeConsumingService was not being set.

      My SP has no RPUI extension, but does have a ServiceName (with lang="en") in the ACS.

      Anybody able to shed some light into it?

      Would this count as a bug?

      Many thanks in advance!

      Cheers,
      Vlad

        Attachments

          Activity

            People

            Assignee:
            cantor.2@osu.edu Scott Cantor
            Reporter:
            vme28@canterbury.ac.nz Vladimir Mencl
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Time Tracking

                Estimated:
                Original Estimate - Not Specified
                Not Specified
                Remaining:
                Remaining Estimate - 0 minutes
                0m
                Logged:
                Time Spent - 30 minutes
                30m