Uploaded image for project: 'Spring Extensions'
  1. Spring Extensions
  2. JSE-28

remove SVN resource support

    XMLWordPrintable

    Details

    • Type: Task
    • Status: Resolved
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: 5.3.0
    • Fix Version/s: 6.0.0
    • Labels:
      None

      Description

      We've decided to remove support for SVN resources in IdP V4.0, and the two classes that implement that are deprecated in spring-extensions v5 today.

      For v6 of spring-extensions (for Java 8 and beyond, as will be used by IdP V4.0) we can and should remove the two deprecated classes and their managed optional dependency on the svnkit artifact.

      We should also remove the managed depdency for the svnkit artifact from the v8 parent project.

      One benefit of this is that we can stop worrying about the licensing morass associated with svnkit.

        Attachments

          Activity

            People

            Assignee:
            ian@iay.org.uk Ian Young
            Reporter:
            ian@iay.org.uk Ian Young
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Time Tracking

                Estimated:
                Original Estimate - Not Specified
                Not Specified
                Remaining:
                Remaining Estimate - 0 minutes
                0m
                Logged:
                Time Spent - 51 minutes
                51m