The method SAMLMetadataSupport.getDescriptorExtensions is misnamed, as it returns a single object, not all appropriate objects. We should rename it appropriately. This is an API change, so can't appear in 0.9.x.
Meanwhile, we actually want to have a method on the 0.9.x branch which returns all of the appropriate objects. That will have to be called getDescriptorExtensionsAll for now, and be renamed to getDescriptorExtensions for 0.10.0.